Home Download News FAQ / Knowledge Base Screenshots Documentation Support Site map
philosophical imaginary

citserver fails to start with a message such as cdb_*:dbenv->open: Function not implemented

This happens when you've got more than one copy of Berkeley DB installed on your machine, and citserver linked to the wrong one. Sometimes this even happens when Citadel is reporting that it found the correct version. When you install DB 4.1.25, make sure there are no older libdb-4.1.so files lying around on your system. For example, there might be an old one sitting in lib when the real one you want is in /usr/lib.

If you don't know much about libraries and linkage, and just want the Citadel system to work, you should probably use Easy Install to get the software up and running automatically.

If you're really stuck, you can always configure Berkeley DB as a static library. You can do this by building Berkeley DB with a command like:

./configure --prefix=/usr/local/citadel-db4 --enable-static --disable-shared

…and then building Citadel with a command like this:

./configure --with-db=/usr/local/citadel-db4

This will link libdb directly into the citserver binary, eliminating runtime conflicts.

Copyright © 1987-2014 Uncensored Communications Group. All rights reserved.     Login (site admin)