Home Download News FAQ / Knowledge Base Screenshots Documentation Support Site map
philosophical imaginary

Differences

This shows you the differences between two versions of the page.

installation:debian [2014/07/29 10:47]
dothebart [Debug Flags]
installation:debian [2014/07/29 10:54] (current)
dothebart syntax enhancements
Line 10: Line 10:
 and then do  and then do 
  
-  apt-get update +<code bash> 
-  apt-get install citadel-suite+apt-get update 
 +apt-get install citadel-suite 
 +</code>
  
 in order to get all Citadel components installed at once and your MTA replaced by Citadel. **Be sure to have a look at the [[installation:getting_started|Getting Started]] and some of its articles.** in order to get all Citadel components installed at once and your MTA replaced by Citadel. **Be sure to have a look at the [[installation:getting_started|Getting Started]] and some of its articles.**
Line 57: Line 59:
      
 then do: then do:
-  apt-get update +<code bash> 
-  apt-get source libical0 +apt-get update 
-  cd libical0-0.26.6 +apt-get source libical0 
-  fakeroot dpkg-buildpackage+cd libical0-0.26.6 
 +dpkg-buildpackage 
 +</code>
    
 if it complains about missing build dependencies, install them via "apt-get install", and repeat the above step. Then do: if it complains about missing build dependencies, install them via "apt-get install", and repeat the above step. Then do:
-  cd .. +<code bash> 
-  dpkg -i libical0*.deb +cd .. 
-  apt-get source citadel-server +dpkg -i libical0*.deb 
-  cd citadel-<tab> "(to make it expand the version number)"  +apt-get source citadel-server 
-  fakeroot dpkg-buildpackage +cd citadel-<tab> "(to make it expand the version number)"  
-  cd .. +dpkg-buildpackage 
-  apt-get source webcit +cd .. 
-  cd webcit-<tab> +apt-get source webcit 
-  fakeroot dpkg-buildpackage"+cd webcit-<tab> 
 +dpkg-buildpackage"
 +</code>;
    
 Then install the "citadel-*" packages you need. You might not want to install the "-mta" package, if you want to stay with another mail transport agent. Then install the "citadel-*" packages you need. You might not want to install the "-mta" package, if you want to stay with another mail transport agent.
Line 82: Line 88:
 ====== To build from source [git] ======  ====== To build from source [git] ====== 
 1) Install the requirements to bootstrap and compile citadel: 1) Install the requirements to bootstrap and compile citadel:
-  apt-get install build-essential autoconf libtool git+<code bash> 
 +apt-get install build-essential autoconf libtool git 
 +</code>
 2) [[installation:sourcecode|obtain a git clone of the citadel repository]].  2) [[installation:sourcecode|obtain a git clone of the citadel repository]]. 
  
 3) change into a component subdirectory (ala citadel/webcit/) and run 3) change into a component subdirectory (ala citadel/webcit/) and run
-  ./bootstrap +<code bash> 
 +./bootstrap 
 +</code> 
 4) after that build the package using dpkg-buildpackage as stated above. 4) after that build the package using dpkg-buildpackage as stated above.
  
Copyright © 1987-2014 Uncensored Communications Group. All rights reserved.     Login (site admin)